Consumers - Timbuktu Pro for Macintosh 8.x: System Requirements
FAQs

ARRIS Consumer Care

Article

Timbuktu Pro for Macintosh 8.x: System Requirements

« Go Back

Information

 
Question

What are the system requirements for my Timbuktu Pro for Mac?

Answer

System Requirements for Timbuktu Pro for Macintosh

Timbuktu Pro Mac version 6.0 or later will function correctly on any Macintosh system that meets or exceeds both hardware and software requirements.
 


Macintosh System Requirements

Hardware Requirements:
  • 15 MB of available disk space.
  • 128 MB of physical RAM.
  • TCP/IP network connection or a modem.
  • For modem connections, a 56 Kbps or faster modem.
  • For the Intercom service or Skype™, a microphone and speakers on each computer.

    NOTE: Skype is only supported on versions 8.6 - 8.8.2.
Software Requirements:
  • One copy of Timbuktu Pro software on each computer that is to make or receive Timbuktu Pro connections.
  • Timbuktu Pro 8.8.4 requires your Mac to be running Mac OS X 10.8 (Mountain Lion), 10.7 (Lion), or 10.6 (Snow Leopard).
  • Timbuktu Pro 8.7 requires your Mac to be running Mac OS X 10.5 (Leopard), or 10.4 (Tiger).
  • Timbuktu Pro 8.6 requires your Mac to be running Mac OS X 10.3.9 or 10.4 (Tiger).  It will not run under earlier versions of Mac OS X or on Mac OS 9.
  • The download site and the CD include older versions of Timbuktu Pro for use with Mac OS X 10.6 and Mac OS classic.


Timbuktu Pro Macintosh Compatibility List

NOTE: Timbuktu Pro Macintosh version 6.x and earlier are no longer supported.
 
Timbuktu VersionCompatible Operating SystemBackward Compatibility with Timbuktu MacBackward Compatibility with Timbuktu WindowsPower PC or Intel Mac
8.8.510.6.x to 10.10.xPro 6.0Pro 5.0Intel Mac
8.8.410.6.x to 10.8.xPro 6.0Pro 5.0Intel Mac
8.8.310.6.x to 10.8.xPro 6.0Pro 5.0Intel Mac
8.810.4.x to 10.6.xPro 6.0Pro 5.0Power PC and Intel Mac
8.7.x10.4.x to 10.5.xPro 6.0Pro 5.0Power PC and Intel Mac
8.610.3.9 to 10.4.xPro 6.0Pro 5.0Power PC and Intel Mac
8.510.3 to 10.4.xPro 6.0Pro 5.0Power PC
8.1.110.3 to 10.4.xPro 6.0Pro 5.0Power PC
8.0.110.3 to 10.3.9Pro 6.0Pro 4.5Power PC
7.0.410.2.8 to 10.3.9Pro 5.2.4Pro 4.5Power PC
7.0.310.2.8 to 10.3.9Pro 5.2.4Pro 4.5Power PC
7.0.110.2.8 to 10.3.9Pro 5.2.4Pro 4.5Power PC
7.010.2.8 to 10.3.9Pro 5.2.4Pro 4.5Power PC
6.0.38.6 to 10.2.6Pro 4.8Pro 2000Power PC
6.0.28.6 to 9.2.x and 10.0.4 to 10.2.xPro 4.8Pro 2000Power PC
6.0.110.0.4 and 8.6 to 9.2.xPro 4.8Pro 2000Power PC
6.010.0.4Pro 4.8Pro 2000Power PC

Feedback

 

Was this article helpful?


   

Your feedback is appreciated.

Characters Remaining: 255

 

Print
-->